Installation

pyrolite is available on PyPi, and can be downloaded with pip:

pip install pyrolite

Note

pyrolite is not yet packaged for Anaconda, and as such conda install pyrolite will not work.

Upgrading pyrolite

New versions of pyrolite are released frequently. You can upgrade to the latest edition on PyPi using the --upgrade flag:

pip install --upgrade pyrolite

Optional Dependencies

Optional dependencies (dev, skl, spatial, db) can be specified during pip installation. For example:

pip install pyrolite[dev]

pip install pyrolite[dev,skl,spatial,db]